Back to overview
Degraded
Degraded Service
Aug 11 at 10:30am EDT
Affected services
dialer.enrollhere.com
Resolved
Aug 11 at 10:40am EDT
The earlier issues with our third-party providers affecting phone activity have been resolved, we will continue to monitor for any follow on issues.
Affected services
Created
Aug 11 at 10:30am EDT
There is currently some issues related to the telecommunications carriers - we are investigating, this is a industry wide issues affecting everyone including traffic sources
Affected services