Back to overview
Degraded

Website partial downtime and API failures due to issues with Cloudflare

Nov 18 at 07:50am EST
Affected services
api.enrollhere.com
dialer.enrollhere.com

Resolved
Nov 18 at 10:16am EST

Calls flowing in a normal rate

Updated
Nov 18 at 09:06am EST

API fully reachable

Updated
Nov 18 at 08:21am EST

Some calls might not be connected